Wednesday, May 20, 2009

Installing Sun VirtualBox guest additions for Ubuntu

I found that Ubuntu 9.04 works better in Sun’s VirtualBox – the cursor was way off in Microsoft’s Virtual PC - the only problems were the screen resolution and the annoying bit with capturing the mouse and having to use the scape key. That is until I found that Sun provides guest additions for Ubuntu, see this post here on how to install.

Wednesday, May 6, 2009

Windows 7 RC on ASUS R2H

I hope Microsoft fixed everything in this version as I’m getting a bit tired of installing all these Windows 7 releases :-) to be honest though is not the actual Windows installation as that takes only about a half an hour and it needs your input only on a couple of things, but installing all the other drivers and apps, and lastly to customize things as you prefer.

Probably because I rarely use computers for leisure and mostly for work or doing some coding for a hobby (some may find sad the idea of having a hobby same as your main occupation :-), I like my computers running quick with little visual effects, although luckily for me and my job, I do try to keep a balance between useful and pretty as much as possible when developing stuff. In this case, with the R2H I prefer it to be a little snappier rather than waiting for drop-down to come down nice and slow, anyways you get the idea. Some of the customisations include changing from Segoe UI font back to good old Tahoma 8pt (some of the windows I noticed keep using Segoe even after the change), removing the wallpaper, disabling ClearType (I usually like texts nice and crisp, except maybe for a few specific applications like Adobe Reader or in coding editors), setting the System Properties > Performance Options for best performance, except maybe for Show shadow under mouse pointer (ironically, I still keep this one...), Smooth edges on screen fonts (that’s the basic font smoothing) and Use visual styles on windows and buttons (I don’t use this one on XP, only on W7, that much I like the theme in W7 :-), setting up Process Explorer to startup minimized when logging on (like to keep an eye on the system) and some changes in Explorer, like showing all file extensions, displaying the full path in the titlebar, sorting by default by type and applying the settings to all folders, enabling single click to open items etc. Enough about me, back to Windows 7 RC...

Finishing the installation from a DVD-RW, you need to connect it to the Internet through the Ethernet cable and that should install about 6 updates: Atheros Wireless driver, AuthenTec finger-print driver - a nice addition Dave spotted earlier, Intel 915 chipset driver, ATK Input ACPI utility and a couple of IE8 related updates. There’s also an optional Realtek wired network driver, checking that box as well. 38 MB worth updates and a reboot later, we have a nice and slightly slow R2H running W7 :-) only messing, doing the above will make it snapier without much loss of the actual W7 experience.

Touch Screen

Working fine, it needs calibrating.


The default drivers works fine, although I’ve noticed W7 installed Standard VGA Graphics adapter which scores a double 1.0 in Windows rating and I’ve also noticed some flickering in Google Chrome dialog windows and when running Mobility Center when it’s being drawn up, which is just as well, we are going to install the ASUS Intel Graphics driver for Vista v6.14.10.4764 (in Windows Vista SP1 compatibility mode). After rebooting, noticeably less flickering and scoring now 1.9 in desktop performance and same 1.0 in 3D – still no Halo3 on R2H :-)


Same as before, the output doesn’t switch automatically from headphones to speaker, install ASUS Audio driver for Vista v6.10.1.6030.

WebCam (Bison)

Not installed by default, detected as USB2.0 Camera, install ASUS drivers for Vista v6. (if you don’t have a Bison webcam user your Vista driver or download the appropriate one from, they explain which driver to download based on hardware IDs).

Some may find interesting, Dave reported earlier he uses ASUS SmartLogon for face recognition for logging on in W7 (no download link just yet, google yourself for “ASUS SmartLogon download”).


Same as before, install the ASUS Touchpad driver for Vista v9.1.5.0 for better sensitivity and click on push.

Wired network (Ethernet)

Works fine out of the box, there is a newer driver through Windows Update.

Wireless (Atheros)

Same as before, works fine with the default driver, the ASUS Wireless Console for Vista v2.0.8 needs though the ASUS Hotkey Utility v1.00.0012 to be able to enable/disable the device and to get the wireless hardware button working.


Works fine, use the Device Switch utility for Vista v1.0.0.1 to enable the device.

Fingerprint sensor

Driver is now delivered through Windows Update, go to Control Panel > Biometric Devices to enable and register your fingers.

ASUS Settings Center

Install ASUS Hotkey Utility v1.00.0012 then install ASUS Settings Center v1.6.7.115, then reboot or at least logoff and then log back in. Same as before, brightness and volume work ok, for resolution you need the ASUS Intel Graphics driver for Vista v6.14.10.4764.

Note: I couldn’t get the resolution to switch I changed output to Single Display: Notebook from the Intel Graphics Media control panel. The application flickers a lot when you click Ok / Apply, best to use the Enter key on the 15 second OK button otherwise clicking with the mouse it might not work and reverts back to previous settings.


I noticed Hibernation wasn’t available as an option until I installed most of the drivers above – probably one of them wasn’t fully supporting ACPI, I don’t know exactly which one… Resuming for hibernation is fast as in previous builds.

Final thoughts

Looking at Process Explorer > System Information, Windows 7 RC has pretty much the same memory footprint (with disk swap disabled, and default services, haven’t stopped any just yet, like for example the Print Spooler and other’s I’ve listed in original post in the performance tips section). The system feels unnoticeably slower, but that may be because I haven’t stopped any services just yet, nor uninstalled any features I don’t use or maybe it’s just me, or maybe it needs a defrag :-)

Haven’t had any problems, except for a message popped up twice about a “USB device not recognized”, but that may be specific to my setup, when I used it at my desk I connect everything through a hub, including a Thermaltake Mobilefan II, which probably doesn’t send any information back to Windows, just powers from the USB port.

Friday, May 1, 2009

The case of slow Windows Explorer with large number of files…

There’s always one of those cases when your Windows is getting really slow exactly when you don’t need that, you already have your own work problems and now this. You get angry and start thinking not very pleasant things to say to all those hundreds of people they’ve been working on Windows and come up with lots of ways to punish MS by boycotting their software blah blah all and all that.

Well, it just happens that sometimes is not their fault at all :-) Really? :-) Yeah, sometimes. In my case, we have been processing a lot of customer data lately and that gave us a few good hundred thousand of XML files, which sometimes we have to use Windows Explorer to move around, search or delete. You might say there are better file managers out there, and I’ve tried a few like Total Commander and Free Commander, but they were pretty much as fast and they managed to hang pretty much like Windows Explorer did.

I beared it as long as I could and then it stroke me, what if Explorer is doing more than it should? This is where FileMon enters the stage – I used the opportunity to say a big thanks to to Mark Russinovich and Bryce Cogswell for writing it and making it available to us all, for free.

And what do you know, after selection a bunch of files using CTRL+A (no problems there), for operations like CTR+C or right-click on the list, or even after you push the delete icon and when it says “Preparing to delete”, there’s a REALLLY LOOOOONG list of lookups on C:\Program Files\WinRAR\formats\ directory! what?! So all this time, I’ve been swearing at the wrong bunch :-)

Uninstalled WinRAR 3.80 and performed the same tests, and the difference in responsiveness is huge, given the large number of files I was working with. I’ll try to follow this up with WinRAR guys, but I guess it’s back to compressed (zip) folders for now :-)

Update 05 May 2009:

Reported the problem to WinRAR last week and Eugene Roshal, the author of WinRAR, answered the problem promptly and made a few changes in WinRAR 3.90 beta 1 - things are looking much better now!