Tuesday, January 30, 2007

Windows Live Messenger not conecting/hanging on Windows Vista

I finally found a way to make Live Messenger work on Vista, it was hanging so badly even Vista wasn't able to kill the application, either from Task Manager or at logoff/shutdown. Interestingly enough if hibernated and then resumed the process disappears.

Basically you have to add the msnnsgr.exe program in the firewall exceptions - (classic view) Control Panel > Windows Firewall.

If it's still not connecting, try the following found on Microsoft newsgroups.

I found the procedure below in another group, and it solved my problem with Vista and Live Messenger. Apparently Vista's "auto-tuning" networking feature doesn't play nice with some routers. Not sure if it is a bug in Vista, a bug in Messenger or a bug in the router firmware but anyway this looks like a possible workaround that might help other people who have the same problem. BTW I have a NetGear DG834

Try this:
- Click start
- Type: cmd
- Right-click cmd.exe when it appears under Applications
- Click Run As Administrator
- Type the following:
netsh int tcp set global autotuninglevel=disabled
- Press enter
- Restart your computer

To check autotuning is disabled repeat the above but type:
netsh int tcp show global

Sunday, January 28, 2007

How to build a USB desk fan

While I'm still looking to get a couple of Thermaltake Mobile II fans, as I was going yesterday through some things, I realized I had everything to build one on my own.

This article on Engadget gave me the idea - I already had a Microsoft Blue USB mouse that wasn't working anymore, a Zalman ZM-OP1 fan and the fan cage from my Shuttle SB61G2V3 XPC (I'm wasn't using the last two, as I've modded my Shuttle to mount a 92mm fan Vantec Stealth externally with an aluminium 80 to 92mm adapter).

Cut the mouse cable, strip out the red and black wires, those are the ones for power, we won't use the other two, used for transmitting data.

The Zalman OP-1 is a 12V DC fan, 0.14A, which makes it good for the job, as the USB ports output a 5V, 500mA current on each port. This fan is very quiet in normal operation, even quieter now that's running on 5V current. The fan has a 3pin connector, red and black wires are for power, and the third wire is for speed readings.

Mount the fan in the aluminium fan cage, add a 80mm silicone fan gasket and a fan grill to give it look a professional look ;-) and here is the finished "product".

This is quite useful if you use the R2H in it's stand, you can put the fan blowing air in the hard-disk air vent along the back of the unit. If you take the battery pack off you can get around 40 degrees C for HDD and 50 degrees C for CPU - not too bad.

Update 24-02-2007
I finally found the Thermaltake Mobilefan II at Performance-Pcs.com, and even if they weren't the cheapest around, it is one of the few websites shipping to Europe.

Wednesday, January 24, 2007

UMPC external keyboard

I've been looking for a nice compact, mini-keyboard to use with my Asus R2H - the Logitech Playstation USB keyboard reviewed on jkOnTheRun looks good, but I couldn't find it here in Europe.

If you've seen any good reviews, or if you already have one that you are happy with, please let me know.


Saturday, January 20, 2007

R2H Wireless woes (2)

Just found this tip on the Asus support forums from Helmuth, Germany, on how to disable the power management for the USB hub where the wireless chip is connected to. Give it a try and see if it makes any difference for you.

Open Computer Management console (Run -> compmgmt.msc), go to Device Manager, expand Universal Serial Bus controllers, go to the last USB Root Hub entry and double click it (Properties).

Select Power Management tab, and deselect the Allow the computer to turn off...

Friday, January 19, 2007

Wireless WDS link

I have succeeded recently to create a WDS link between the two 3Com routers I had around, and I thought I might share the experience with you guys, as it took me a while to get this to work.

The first router I bought a couple of years ago was in fact a 3Com OfficeConnect ADSL router (3CRWDR100A-72), and obviously I got it because I had an ADSL connection at the time. One thing that I liked was that it supported WDS, although I didn't have a use for it righ away, I thought it might come handy someday (and you will see, it did :-)

Last year we moved in our own house and one thing I was looking forward to was to get NTL internet cable, available in the area. Since the old router wasn't going to work with the cable, I bought another one, and I did go for a 3Com again, the OfficeConnect Wireless 11g DSL/Cable Router (3CRWE554G72T). Again, the new router had support for WDS, and it looked like a nice feature to have, as I was thinking that I could connect the two of them if needed.

As I had setup my desktop computer in the small bedroom upstairs, now converted to my own office (yeah!), I asked the cable guys to set up the connection up there as I wanted to have low pings on the net for some online gaming. My wife's Vaio notebook would connect wirelessly from anywhere around the house, so the whole setup made sense.

Recently we've managed to furnish the living room downstairs, and now I could finally bring the TV and the Xbox downstairs, but the question was how to connect the Xbox to the Internet. I looked around for a wireless gateway to be able to connect the Xbox to the wireless router, but I haven't found one for a good price, and then I remembered about my old ADSL router lying around...

As this was an ADSL router, I didn't have high hopes for it, as I was worried that the router would only know to route packages through the dynamic routes created when it connected to the PPPoE server through ADSL. I read up a few articles on the Internet, and the first attempt failed miserably, later on realizing that I was trying to use WPA encryption on both routers, as they were configured when they were used on their own.

I dropped the idea for a while, and decided to get one (or even two) of the new 3Com routers that claim to support WPA over WDS links. I read some more, and I decided to give it another shot, this time starting with no encryption. As one of the articles suggested, I got my 8-port ethernet hub from the old stuff (but always useful ;-) pile, and wire in the two routers and the desktop.

I started by disabling the DHCP servers on both routers, set-up static IPs on the routers as well as on the desktop, to avoid any issues involving DHCP - all IPs were in the same private class (10.xx.xx.xx). I also disabled the NAT support from the ADSL router, as the NATing was going to be performed by the cable router. I configured the routers to use the same wireless channel (the SSIDs do not have to be the same), enabled WDS support, configured the MACs for WDS on both routers and as soon as I saved the configuration, the lights on the hub started blinking quickly, as one of the articles said it would happen, because the packets were going in a loop from the wired connection, through the wireless, and then back through the wired connection. Hurray, there was hope that all the work wasn't in vain!!! I re-configured the routers to use WEP-128 encryption, lights blinking happily, even better news! Tried it once just for the sake of it with WPA-PSK, no sign of life, but I felt happy enough to go back to WEP and try the hole again, this time from downstairs. I decided to stick with the static IPs, plugged-in the Xbox, set the IP and voila, Internet through the wireless WDS link! Now after the couple of hours spent researching, trying, failing and then trying again, we finally deserved a nice long sleep :-)

Sunday, January 7, 2007

ASUS Security Protect Manager

ASUS Security Protect Manager improves system security and productivity by consolidating user passwords and network accounts within a User Identity and allow secure and convenient access to registered applications after logon to the ASUS Security Protect manager.

I found that Single Sign On (SSO) component takes a bit of the CPU when a webpage is loaded in IE (I use IE7), as the application is trying to record the logon details and help with subsequent logons. I have used IE AutoComplete for username and passwords on forms for a while now, so I don't really find SSO very useful, but I'm sure that other people may do.

You can disable SSO for a particular application, using the icon in the application title bar:

You can disable SSO for all applications by accessing the Settings and Options entry from the tray icon:

Wednesday, January 3, 2007

Windows XP Tweaks - Tweak UI

This PowerToy gives you access to system settings that are not exposed in the Windows XP default user interface, including mouse settings, Explorer settings, taskbar settings, and more.

Download and install Tweak UI from here.

Here are a couple of tweaks that I like most:

Speed up menus

Classic search in Explorer

Document template - New menu

Command Prompt - Filename/directory completion